Batch SaaS US1 - API call failures

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 23:55 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2026 - 22:50 UTC

Update

The service outage in Batch SaaS US1 has now been mitigated.

Customers may see delays and experience degraded performance. We recommend using Batch SaaS US2 region until US1 is fully operational.

We are working on restoring service to normal operational status in Batch SaaS US1.
Posted Jan 06, 2026 - 22:13 UTC

Identified

The issue has been identified and a fix is being implemented.

We recommend using Batch SaaS US2 region until US1 is fully operational.

We apologise for any inconvenience.
Posted Jan 06, 2026 - 21:30 UTC

Investigating

We’re currently experiencing an outage in our Batch SaaS US1 region. Customers may see API call failures and delays.

Our team is currently working to restore availability and normal performance levels.

We apologise for any inconvenience.
Posted Jan 06, 2026 - 21:08 UTC
This incident affected: Batch SaaS - US (Batch SaaS - US1).