Partial outage in Batch SaaS and Portal
Incident Report for Speechmatics
Resolved
We have continued to monitor this incident and can confirm it has now been resolved.
We apologise for any inconvenience caused. If you are still facing issues with the service, please reach out to our support team here https://support.speechmatics.com/hc/en-gb or at support@speechmatics.com.
Posted Jan 26, 2023 - 09:09 UTC
Update
The global networking outage impacting our cloud vendor has now been mitigated. The service has now been restored to normal operational status.
We will continue to monitor the situation for any changes.
Posted Jan 25, 2023 - 11:21 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 25, 2023 - 09:21 UTC
Monitoring
A global networking outage impacting our cloud vendor is also affecting all of our SaaS products. It has now been mitigated by them and the service is returning to normal operational status.

We will continue to monitor the situation for any changes.
Posted Jan 25, 2023 - 07:30 UTC
This incident affected: Batch Cloud - EU, Batch Cloud - US, portal.speechmatics.com, RT Cloud US, and RT Cloud EU.