Increased connect time to Realtime SaaS - US

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Dec 11, 2025 - 17:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2025 - 16:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 11, 2025 - 15:45 UTC

Investigating

We’re currently experiencing degraded performance in our Realtime SaaS - US region. Customers may see delay in session connect time.

Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Dec 11, 2025 - 15:37 UTC
This incident affected: Realtime SaaS - US.