Billing page unavailable

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Jan 29, 2026 - 12:55 UTC

Monitoring

The Billing page is now accessible for most users. Intermittent issues may still occur whilst a fix is being deployed. The underlying cause has been identified and full resolution is expected shortly.
Posted Jan 28, 2026 - 12:19 UTC

Identified

The Billing page is currently unavailable due to an issue with our third-party billing provider. We are actively investigating and will post an update once the issue is resolved.
Posted Jan 27, 2026 - 17:27 UTC
This incident affected: Portal (portal.speechmatics.com).