portal.speechmatics.com UI - Partial outage
Incident Report for Speechmatics
Resolved
We have seen no further issues since rolling out the fixes.

This incident is now resolved.

We apologize for any inconvenience caused.
Posted Sep 29, 2023 - 15:26 UTC
Monitoring
A fix to billing and card payments functionality has been deployed. We are now monitoring for further issues.
Posted Sep 29, 2023 - 14:50 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 29, 2023 - 10:05 UTC
Update
We have deployed a workaround to temporarily disable card payment functionality. Other Portal functionality has been restored and we are continuing to work on a fix for payments.
Posted Sep 29, 2023 - 09:59 UTC
Identified
We have identified the cause of the issues and we are working on a fix.
Posted Sep 29, 2023 - 09:35 UTC
Investigating
We’re experiencing a service outage on portal.speechmatics.com UI. Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Sep 29, 2023 - 09:20 UTC
This incident affected: portal.speechmatics.com.