Degraded service in billing reporting

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 09:14 UTC

Update

Some users may still experience a delay in their usage appearing on the Billing page, as the backlog of billing usage is processed. An update will be provided when this incident is fully resolved.
Posted Apr 14, 2026 - 10:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Usage in the Billing page may still be delayed for some users.
Posted Apr 10, 2026 - 15:31 UTC

Update

We are continuing to investigate this issue.
Posted Apr 10, 2026 - 11:59 UTC

Investigating

We are currently investigating an issue with our billing service which may delay usage appearing on the Billing page in the portal.
Posted Apr 10, 2026 - 11:58 UTC
This incident affected: Portal (portal.speechmatics.com).