portal.speechmatics.com

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Dec 08, 2025 - 15:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2025 - 15:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 08, 2025 - 13:37 UTC

Investigating

We’re experiencing an issue generating invoices from portal.speechmatics.com. Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Dec 08, 2025 - 13:22 UTC
This incident affected: Portal (portal.speechmatics.com).