Investigating - Degraded performance

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Apr 25, 2026 - 07:22 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2026 - 18:29 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2026 - 14:50 UTC

Identified

The root cause has been identified and we are working on a solution.
Posted Apr 24, 2026 - 14:03 UTC

Investigating

We’re currently experiencing degraded performance in our US2 region. Customers may see degrading experience.
We recommend using US1 endpoint until the issue is resolved.

Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Apr 24, 2026 - 13:32 UTC
This incident affected: Batch SaaS - US (Batch SaaS - US2).