Investigating - Degraded performance in Batch SaaS Australia region

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Apr 17, 2026 - 03:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2026 - 03:23 UTC

Investigating

We’re currently experiencing degraded performance in our Batch SaaS AU region. Customers may see delays is processing jobs for audio duration > 12 mins.

Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Apr 17, 2026 - 02:49 UTC
This incident affected: Batch SaaS - AU (Batch SaaS - AU).