Slower than normal processing times for real-time transcription affecting a subset of sessions

Incident Report for Speechmatics

Resolved

We've continued to monitor this incident and can confirm it has now been resolved.

We apologise for any inconvenience caused. If you are still facing issues with the service, please reach out to our support team here https://support.speechmatics.com/hc/en-gb.
Posted Aug 28, 2025 - 16:00 UTC

Monitoring

We have applied mitigations to address the slowdown in real-time transcription processing. Early results show recovery and improved performance for affected customers. Our team will continue to monitor closely to ensure the service remains stable.
Posted Aug 28, 2025 - 14:45 UTC

Update

We have identified the cause of the slowdown in real-time transcription processing affecting a subset of customers.
We are currently applying mitigation and will continue to monitor the impact as the fix progresses.
Posted Aug 28, 2025 - 14:33 UTC

Update

We are continuing to monitor our services.
Posted Aug 28, 2025 - 14:32 UTC

Identified

We have identified the cause of the slowdown in real-time transcription processing affecting a subset of customers.
We are currently applying mitigation and will continue to monitor the impact as the fix progresses.
Posted Aug 28, 2025 - 14:31 UTC

Investigating

We are currently observing slower than normal processing times for real-time transcription affecting a subset of sessions.
Our team is actively investigating the issue. We will provide an update as soon as more information is available.

We apologise for any inconvenience.
Posted Aug 28, 2025 - 13:46 UTC
This incident affected: RT Cloud US and RT Cloud EU.