Investigating - Degraded performance

Incident Report for Speechmatics

Resolved

After monitoring this incident, we can confirm it has now been resolved.

We apologise for any inconvenience caused. If you are still facing issues with the service, please reach out to our support team here https://support.speechmatics.com.
Posted Apr 21, 2026 - 12:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 09:29 UTC

Identified

The root cause has been identified and we are working on a solution.
Posted Apr 21, 2026 - 08:50 UTC

Investigating

We’re currently experiencing degraded performance in our RT EU region. Customers may see capacity errors.

Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Apr 21, 2026 - 07:45 UTC
This incident affected: Realtime SaaS - EU.