Partial portal outage

Incident Report for Speechmatics

Resolved

This incident has been resolved. Sign-ups and access of billing details in the portal should now be fully operational.
Posted Oct 27, 2025 - 13:45 UTC

Identified

We have identified an issue affecting portal sign-ups and access of billing details in the portal.
Posted Oct 27, 2025 - 13:36 UTC
This incident affected: Portal (portal.speechmatics.com).