Portal and temporary auth key API outage

Incident Report for Speechmatics

Resolved

We have continued to monitor this incident and can confirm it has now been resolved.

We apologise for any inconvenience caused. If you are still facing issues with the service, please reach our to our Support team https://support.speechmatics.com.
Posted Sep 25, 2025 - 16:32 UTC

Update

In the Portal, the Usage and Billing pages will have delayed updates temporarily.
Posted Sep 25, 2025 - 16:29 UTC

Monitoring

We have rolled out a mitigation for creating new API and temporary tokens and the service has recovered.

We will continue to monitor as top priority.
Posted Sep 25, 2025 - 15:54 UTC

Update

Root cause has been identified as a problem with the backend service supporting creation of new API and temporary keys.

A fix is in the process of being rolled out.

We will post another update within 15 minutes.
Posted Sep 25, 2025 - 15:34 UTC

Identified

The root cause has been identified and our engineering teams are working on a solution.

We apologise for any inconvenience caused.
Posted Sep 25, 2025 - 15:15 UTC

Investigating

We’re experiencing a partial outage on portal.speechmatics.com. Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Sep 25, 2025 - 15:02 UTC
This incident affected: Batch SaaS - EU (Batch SaaS - EU1, Batch SaaS - EU2), Batch SaaS - US (Batch SaaS - US1, Batch SaaS - US2), Batch SaaS - AU (Batch SaaS - AU), and portal.speechmatics.com, Realtime SaaS - US, Realtime SaaS - EU.