Batch SaaS US1 - API call slowness and failures

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Jan 07, 2026 - 09:45 UTC

Monitoring

We have implemented mitigation measures, and the service has recovered. US1 Batch SaaS is currently operational.
Posted Jan 07, 2026 - 07:39 UTC

Investigating

We’re currently experiencing an degraded performance in our Batch SaaS US1 region. Customers may see API call failures and delays.

Our team is currently working to restore availability and normal performance levels.

We recommend using Batch SaaS US2 region until US1 is fully operational.

We apologise for any inconvenience.
Posted Jan 07, 2026 - 06:55 UTC
This incident affected: Batch SaaS - US (Batch SaaS - US1).