Management Platform - Service credits applied incorrectly

Incident Report for Speechmatics

Resolved

We have fixed the problem and issued refunds to the affected customers. Please email support if you still believe you are having issues.

Once again, we're sorry for any inconvenience caused by this issue.
Posted Aug 03, 2026 - 15:32 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 03, 2026 - 11:25 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 03, 2026 - 09:30 UTC

Investigating

We are aware of an issue with service credits for July. Some customers may see larger than expected bills.

Our team is working to identify the source of the issue and affected customers.

We apologise for any inconvenience.
Posted Aug 03, 2026 - 09:22 UTC
This incident affected: Management Platform (mp.speechmatics.com).