portal.speechmatics.com - Unable to add payment cards
Incident Report for Speechmatics
Resolved
We have continued to monitor this incident and can confirm it has now been resolved and our service has been restored to fully operational status.
We apologise for any inconvenience caused. If you are still facing issues with the service, please reach our to our support team here https://support.speechmatics.com/hc/en-gb
Posted Apr 01, 2023 - 16:04 UTC
Monitoring
The issue when adding a payment method on portal.speechmatics.com has now been mitigated. The service has now been restored to normal operational status.
We will continue to monitor the situation for any changes.
Posted Mar 31, 2023 - 15:22 UTC
Investigating
Users may experience an error when attempting to add a payment card on portal.speechmatics.com. Our team is currently working to restore this service. We apologize for any inconvenience caused.
Posted Mar 31, 2023 - 14:29 UTC
This incident affected: portal.speechmatics.com.