Batch SaaS and Portal - Partial Outage

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Jul 30, 2024 - 21:36 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 30, 2024 - 15:15 UTC

Monitoring

The Portal and Batch SaaS outage has now been mitigated. The service has now been restored to normal operational status.

We will continue to monitor the situation for any changes.
Posted Jul 30, 2024 - 15:15 UTC

Identified

We have identified the issue as being related to our 3rd-party cloud provider. We are continuing to monitor the incident. We apologise for any inconvenience.
Posted Jul 30, 2024 - 13:07 UTC

Investigating

We’re currently experiencing a partial outage when attempting to access our Batch SaaS or visit portal.speechmatics.com. Customers may see delays.
Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Jul 30, 2024 - 12:43 UTC
This incident affected: Batch SaaS - EU (Batch SaaS - EU1, Batch SaaS - EU2) and portal.speechmatics.com.