Increased connect time and connect failures - RT Cloud EU

Incident Report for Speechmatics

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 14:13 UTC

Identified

The root cause has been identified and our engineering teams are working on a solution.
Posted Sep 04, 2025 - 14:05 UTC

Investigating

We’re currently experiencing a partial outage in our RT Cloud EU region. Customers may see a subset of their requests with increased connect time or connection failures.

Our team is currently working to restore normal performance levels.

We apologise for any inconvenience.
Posted Sep 04, 2025 - 13:40 UTC
This incident affected: RT Cloud EU.